What’s Vulnerable › Vulnerabilities
CVE-2020-13665
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-05-05 · updated 2026-06-17
Description
Access bypass vulnerability in Drupal Core allows JSON:API when JSON:API is in read/write mode. Only sites that have the read_only set to FALSE under jsonapi.settings config are vulnerable. This issue affects: Drupal Drupal Core 8.8.x versions prior to 8.8.8; 8.9.x versions prior to 8.9.1; 9.0.x versions prior to 9.0.1.
Affected products
- Drupal: from 8.8.0 before 8.8.8; from 8.9.0 before 8.9.1; from 9.0.0 before 9.0.1 — fixed in 8.8.8, 8.9.1, 9.0.1
How to fix
Upgrade to a fixed version: Drupal 8.8.8, 8.9.1, 9.0.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2020-13665 or the next vulnerability affects your stack