What’s Vulnerable › Vulnerabilities
CVE-2020-13667
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-05-17 · updated 2026-06-17
- Weakness: CWE-276
Description
Access bypass vulnerability in of Drupal Core Workspaces allows an attacker to access data without correct permissions. The Workspaces module doesn't sufficiently check access permissions when switching workspaces, leading to an access bypass vulnerability. An attacker might be able to see content before the site owner intends people to see the content. This vulnerability is mitigated by the fact that sites are only vulnerable if they have installed the experimental Workspaces module. This issue affects Drupal Core8.8.X versions prior to 8.8.10; 8.9.X versions prior to 8.9.6; 9.0.X versions prior to 9.0.6.
Affected products
- Drupal: from 8.8.0 before 8.8.10; from 8.9.0 before 8.9.6; from 9.0.0 before 9.0.6 — fixed in 8.8.10, 8.9.6, 9.0.6
How to fix
Upgrade to a fixed version: Drupal 8.8.10, 8.9.6, 9.0.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2020-13667 or the next vulnerability affects your stack