What’s Vulnerable › Vulnerabilities
CVE-2020-13674
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-02-11 · updated 2026-06-17
- Weakness: CWE-352
Description
The QuickEdit module does not properly validate access to routes, which could allow cross-site request forgery under some circumstances and lead to possible data integrity issues. Sites are only affected if the QuickEdit module (which comes with the Standard profile) is installed. Removing the "access in-place editing" permission from untrusted users will not fully mitigate the vulnerability.
Affected products
- Drupal: from 8.9.0 before 8.9.19; from 9.1.0 before 9.1.13; from 9.2.0 before 9.2.6 — fixed in 8.9.19, 9.1.13, 9.2.6
How to fix
Upgrade to a fixed version: Drupal 8.9.19, 9.1.13, 9.2.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2020-13674 or the next vulnerability affects your stack