What’s Vulnerable › Vulnerabilities
CVE-2020-13675
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-02-11 · updated 2026-06-17
- Weakness: CWE-284
Description
Drupal's JSON:API and REST/File modules allow file uploads through their HTTP APIs. The modules do not correctly run all file validation, which causes an access bypass vulnerability. An attacker might be able to upload files that bypass the file validation process implemented by modules on the site.
Affected products
- Drupal: from 8.0.0 before 8.9.19; from 9.1.0 before 9.1.13; from 9.2.0 before 9.2.6 — fixed in 8.9.19, 9.1.13, 9.2.6
How to fix
Upgrade to a fixed version: Drupal 8.9.19, 9.1.13, 9.2.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2020-13675 or the next vulnerability affects your stack