What’s Vulnerable › Vulnerabilities
CVE-2020-13677
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-02-11 · updated 2026-06-17
- Weakness: CWE-284
Description
Under some circumstances, the Drupal core JSON:API module does not properly restrict access to certain content, which may result in unintended access bypass. Sites that do not have the JSON:API module enabled are not affected.
Affected products
- Drupal: from 8.0.0 before 8.9.19; from 9.1.0 before 9.1.13; from 9.2.0 before 9.2.6 — fixed in 8.9.19, 9.1.13, 9.2.6
How to fix
Upgrade to a fixed version: Drupal 8.9.19, 9.1.13, 9.2.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2020-13677 or the next vulnerability affects your stack