What’s Vulnerable › Vulnerabilities

CVE-2020-13777

Description

GnuTLS 3.6.x before 3.6.14 uses incorrect cryptography for encrypting a session ticket (a loss of confidentiality in TLS 1.2, and an authentication bypass in TLS 1.3). The earliest affected version is 3.6.4 (2018-09-24) because of an error in a 2018-09-18 commit. Until the first key rotation, the TLS server always uses wrong data in place of an encryption key derived from an application.

Affected products

How to fix

Upgrade to a fixed version: [UNKNOWN] gnutls 3.6.14. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2020-13777 or the next vulnerability affects your stack