What’s Vulnerable › Vulnerabilities
CVE-2020-13925
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 19.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-07-14 · updated 2026-06-17
- Weakness: CWE-78
Description
Similar to CVE-2020-1956, Kylin has one more restful API which concatenates the API inputs into OS commands and then executes them on the server; while the reported API misses necessary input validation, which causes the hackers to have the possibility to execute OS command remotely. Users of all previous versions after 2.3 should upgrade to 3.1.0.
Affected products
- Apache Software Foundation Apache Kylin: from 2.3.0 before 3.1.0 — fixed in 3.1.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Kylin 3.1.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread.html/r021baf9d8d4ae41e8c8332c167c4fa96c91b5086563d9be55d2d7acf%40%3Ccommits.kylin.apache.org%3E
- https://lists.apache.org/thread.html/r250a867961cfd6e0506240a9c7eaee782d84c6ab0091c7c4bc45f3eb%40%3Cuser.kylin.apache.org%3E
- https://lists.apache.org/thread.html/r021baf9d8d4ae41e8c8332c167c4fa96c91b5086563d9be55d2d7acf%40%3Ccommits.kylin.apache.org%3E
- https://lists.apache.org/thread.html/r250a867961cfd6e0506240a9c7eaee782d84c6ab0091c7c4bc45f3eb%40%3Cuser.kylin.apache.org%3E
Get alerted when CVE-2020-13925 or the next vulnerability affects your stack