What’s Vulnerable › Vulnerabilities
CVE-2020-13958
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-11-17 · updated 2026-06-17
Description
A vulnerability in Apache OpenOffice scripting events allows an attacker to construct documents containing hyperlinks pointing to an executable on the target users file system. These hyperlinks can be triggered unconditionally. In fixed versions no internal protocol may be called from the document event handler and other hyperlinks require a control-click.
Affected products
- Apache Software Foundation Apache OpenOffice: from 4.0.0 before 4.1.8 — fixed in 4.1.8
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache OpenOffice 4.1.8. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread.html/r6b2f48cf6c4aad4ebd13f90033162276b0ccae63bea2d3d89cdaf355%40%3Cannounce.openoffice.apache.org%3E
- https://lists.apache.org/thread.html/r6b2f48cf6c4aad4ebd13f90033162276b0ccae63bea2d3d89cdaf355%40%3Cannounce.openoffice.apache.org%3E
Get alerted when CVE-2020-13958 or the next vulnerability affects your stack