What’s Vulnerable › Vulnerabilities
CVE-2020-13962
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-06-09 · updated 2026-06-17
Description
Qt 5.12.2 through 5.14.2, as used in unofficial builds of Mumble 1.3.0 and other products, mishandles OpenSSL's error queue, which can cause a denial of service to QSslSocket users. Because errors leak in unrelated TLS sessions, an unrelated session may be disconnected when any handshake fails. (Mumble 1.3.1 is not affected, regardless of the Qt version.)
Affected products
- Fedoraproject Fedora: 31, 32, 33
- Mumble: 1.3.0
- openSUSE Leap: 15.2
- Qt: from 5.12.2 before 5.12.9; from 5.13.0 through 5.13.2; from 5.14.0 through 5.14.2 — fixed in 5.12.9
How to fix
Upgrade to a fixed version: Qt 5.12.9. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-09/msg00004.html
- https://bugreports.qt.io/browse/QTBUG-83450
- https://github.com/mumble-voip/mumble/issues/3679
- https://github.com/mumble-voip/mumble/pull/4032
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/4X6EDPIIAQPVP2CHL2CHDHJ25EECA7UE/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/UQJDBZUYMMF4R5QQKD2HTIKQU2NSKO63/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/V3IZY7LKJ6NAXQDFYFR4S7L5BBHYK53K/
- https://security.gentoo.org/glsa/202007-18
- http://lists.opensuse.org/opensuse-security-announce/2020-09/msg00004.html
- https://bugreports.qt.io/browse/QTBUG-83450
- https://github.com/mumble-voip/mumble/issues/3679
- https://github.com/mumble-voip/mumble/pull/4032
Get alerted when CVE-2020-13962 or the next vulnerability affects your stack