What’s Vulnerable › Vulnerabilities
CVE-2020-13974
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-06-09 · updated 2026-06-17
- Weakness: CWE-190
Description
An issue was discovered in the Linux kernel 4.4 through 5.7.1. drivers/tty/vt/keyboard.c has an integer overflow if k_ascii is called several times in a row, aka CID-b86dab054059. NOTE: Members in the community argue that the integer overflow does not lead to a security issue in this case.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04, 20.04
- Debian Linux: 9.0
- Linux kernel: before 4.4.227; from 4.5 before 4.9.227; from 4.10 before 4.14.184; from 4.15 before 4.19.128; from 4.20 before 5.4.46; from 5.5 before 5.6.18 — fixed in 4.14.184, 4.19.128, 4.4.227, 4.9.227, 5.4.46, 5.6.18
How to fix
Upgrade to a fixed version: Linux kernel 4.14.184, 4.19.128, 4.4.227, 4.9.227. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00008.html
- http://lists.opensuse.org/opensuse-security-announce/2020-08/msg00009.html
- https://git.kernel.org/pub/scm/linux/kernel/git/tip/tip.git/commit/?id=dad0bf9ce93fa40b667eccd3306783f4db4b932b
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=b86dab054059b970111b5516ae548efaae5b3aae
- https://lists.debian.org/debian-lts-announce/2020/08/msg00019.html
- https://lkml.org/lkml/2020/3/22/482
- https://usn.ubuntu.com/4427-1/
- https://usn.ubuntu.com/4439-1/
- https://usn.ubuntu.com/4440-1/
- https://usn.ubuntu.com/4483-1/
- https://usn.ubuntu.com/4485-1/
- https://www.oracle.com/security-alerts/cpujul2022.html
Get alerted when CVE-2020-13974 or the next vulnerability affects your stack