What’s Vulnerable › Vulnerabilities
CVE-2020-14001
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-07-17 · updated 2026-06-17
- Weakness: CWE-862
Description
The kramdown gem before 2.3.0 for Ruby processes the template option inside Kramdown documents by default, which allows unintended read access (such as template="/etc/passwd") or unintended embedded Ruby code execution (such as a string that begins with template="string://<%= `). NOTE: kramdown is used in Jekyll, GitLab Pages, GitHub Pages, and Thredded Forum.
Affected products
- Canonical Ubuntu Linux: 20.04
- Debian Linux: 9.0, 10.0
- Fedoraproject Fedora: 31, 32
- Kramdown Project Kramdown: before 2.3.0 — fixed in 2.3.0
How to fix
Upgrade to a fixed version: Kramdown Project Kramdown 2.3.0. Check the vendor advisory for mitigations.
References
- https://github.com/gettalong/kramdown
- https://github.com/gettalong/kramdown/commit/1b8fd33c3120bfc6e5164b449e2c2fc9c9306fde
- https://github.com/gettalong/kramdown/compare/REL_2_2_1...REL_2_3_0
- https://kramdown.gettalong.org
- https://kramdown.gettalong.org/news.html
- https://lists.apache.org/thread.html/r96df7899fbb456fe2705882f710a0c8e8614b573fbffd8d12e3f54d2%40%3Cnotifications.fluo.apache.org%3E
- https://lists.debian.org/debian-lts-announce/2020/08/msg00014.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/ENMMGKHRQIZ3QKGOMBBBGB6B4LB5I7NQ/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/KBLTGBYU7NKOUOHDKVCU4GFZMGA6BP4L/
- https://rubygems.org/gems/kramdown
- https://security.netapp.com/advisory/ntap-20200731-0004/
- https://usn.ubuntu.com/4562-1/
Get alerted when CVE-2020-14001 or the next vulnerability affects your stack