What’s Vulnerable › Vulnerabilities
CVE-2020-14058
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-06-30 · updated 2026-06-17
Description
An issue was discovered in Squid before 4.12 and 5.x before 5.0.3. Due to use of a potentially dangerous function, Squid and the default certificate validation helper are vulnerable to a Denial of Service when opening a TLS connection to an attacker-controlled server for HTTPS. This occurs because unrecognized error values are mapped to NULL, but later code expects that each error value is mapped to a valid error string.
Affected products
- Fedoraproject Fedora: 31
- Cloud Manager: all versions
- Squid: from 3.1 through 3.5.28; from 4.0 before 4.12; from 5.0 before 5.0.3 — fixed in 4.12, 5.0.3
How to fix
Upgrade to a fixed version: Squid 4.12, 5.0.3. Check the vendor advisory for mitigations.
References
- http://www.squid-cache.org/Advisories/SQUID-2020_6.txt
- http://www.squid-cache.org/Versions/v4/changesets/squid-4-93f5fda134a2a010b84ffedbe833d670e63ba4be.patch
- http://www.squid-cache.org/Versions/v5/changesets/squid-5-c6d1a4f6a2cbebceebc8a3fcd8f539ceb7b7f723.patch
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/3RG5FGSTCAYVIJPJHIY3MRZ7NFT6HDO7/
- https://security.netapp.com/advisory/ntap-20210312-0001/
- http://www.squid-cache.org/Advisories/SQUID-2020_6.txt
- http://www.squid-cache.org/Versions/v4/changesets/squid-4-93f5fda134a2a010b84ffedbe833d670e63ba4be.patch
- http://www.squid-cache.org/Versions/v5/changesets/squid-5-c6d1a4f6a2cbebceebc8a3fcd8f539ceb7b7f723.patch
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/3RG5FGSTCAYVIJPJHIY3MRZ7NFT6HDO7/
- https://security.netapp.com/advisory/ntap-20210312-0001/
Get alerted when CVE-2020-14058 or the next vulnerability affects your stack