What’s Vulnerable › Vulnerabilities
CVE-2020-14063
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-07-21 · updated 2026-06-17
- Weakness: CWE-79
Description
A stored Cross-Site Scripting (XSS) vulnerability in the TC Custom JavaScript plugin before 1.2.2 for WordPress allows unauthenticated remote attackers to inject arbitrary JavaScript via the tccj-content parameter. This is displayed in the page footer of every front-end page and executed in the browser of visitors.
Affected products
- Tc Custom Javascript Project Tc Custom Javascript: before 1.2.2 — fixed in 1.2.2
How to fix
Upgrade to a fixed version: Tc Custom Javascript Project Tc Custom Javascript 1.2.2. Check the vendor advisory for mitigations.
References
- https://wordpress.org/plugins/tc-custom-javascript/#developers
- https://www.wordfence.com/blog/2020/07/high-severity-vulnerability-patched-in-tc-custom-javascript/
- https://wordpress.org/plugins/tc-custom-javascript/#developers
- https://www.wordfence.com/blog/2020/07/high-severity-vulnerability-patched-in-tc-custom-javascript/
Get alerted when CVE-2020-14063 or the next vulnerability affects your stack