What’s Vulnerable › Vulnerabilities

CVE-2020-14145

Description

The client side in OpenSSH 5.7 through 8.4 has an Observable Discrepancy leading to an information leak in the algorithm negotiation. This allows man-in-the-middle attackers to target initial connection attempts (where no host key for the server has been cached by the client). NOTE: some reports state that 8.5 and 8.6 are also affected.

Affected products

How to fix

Upgrade to a fixed version: OpenSSH 8.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2020-14145 or the next vulnerability affects your stack