What’s Vulnerable › Vulnerabilities
CVE-2020-14150
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-06-15 · updated 2026-06-17
Description
GNU Bison before 3.5.4 allows attackers to cause a denial of service (application crash). NOTE: there is a risk only if Bison is used with untrusted input, and an observed bug happens to cause unsafe behavior with a specific compiler/architecture. The bug reports were intended to show that a crash may occur in Bison itself, not that a crash may occur in code that is generated by Bison.
Affected products
- GNU Bison: before 3.5.4 — fixed in 3.5.4
How to fix
Upgrade to a fixed version: GNU Bison 3.5.4. Check the vendor advisory for mitigations.
References
- https://bugs.gentoo.org/717936
- https://lists.gnu.org/archive/html/info-gnu/2020-04/msg00000.html
- https://bugs.gentoo.org/717936
- https://lists.gnu.org/archive/html/info-gnu/2020-04/msg00000.html
Get alerted when CVE-2020-14150 or the next vulnerability affects your stack