What’s Vulnerable › Vulnerabilities
CVE-2020-14159
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-06-15 · updated 2026-06-17
- Weakness: CWE-89
Description
By using an Automate API in ConnectWise Automate before 2020.5.178, a remote authenticated user could execute commands and/or modifications within an individual Automate instance by triggering an SQL injection vulnerability in /LabTech/agent.aspx. This affects versions before 2019.12.337, 2020 before 2020.1.53, 2020.2 before 2020.2.85, 2020.3 before 2020.3.114, 2020.4 before 2020.4.143, and 2020.5 before 2020.5.178.
Affected products
- ConnectWise Automate Api: before 2019.12.337; from 2020 before 2020.1.53; from 2020.2 before 2020.2.85; from 2020.3 before 2020.3.114; from 2020.4 before 2020.4.143; from 2020.5 before 2020.5.178 — fixed in 2019.12.337, 2020.1.53, 2020.2.85, 2020.3.114, 2020.4.143, 2020.5.178
How to fix
Upgrade to a fixed version: ConnectWise Automate Api 2019.12.337, 2020.1.53, 2020.2.85, 2020.3.114. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2020-14159 or the next vulnerability affects your stack