What’s Vulnerable › Vulnerabilities
CVE-2020-1416
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-07-14 · updated 2026-06-17
- Weakness: CWE-269
Description
An elevation of privilege vulnerability exists in Visual Studio and Visual Studio Code when they load software dependencies, aka 'Visual Studio and Visual Studio Code Elevation of Privilege Vulnerability'.
Affected products
- Microsoft Azure Storage Explorer: all versions
- Microsoft TypeScript: all versions
- Microsoft Visual Studio 2017 version 15.9 (includes 15.0 - 15.8): from 15.0 before 15.9.25 — fixed in 15.9.25
- Microsoft Visual Studio 2019: from 16.0 before 16.0.16; from 16.1 before 16.4.11; from 16.5 before 16.6.4 — fixed in 16.0.16, 16.4.11, 16.6.4
- Microsoft Visual Studio Code: before 1.47.1 — fixed in 1.47.1
- Microsoft Azure Storage Explorer: all versions
- Microsoft Visual Studio 2019 version 16.4 (includes 16.0 - 16.3): all versions
- Microsoft Visual Studio 2019 version 16.6 (includes 16.0 - 16.5): all versions
- Microsoft TypeScript: all versions
- Microsoft Visual Studio 2017 version 15.9 (includes 15.0 - 15.8): all versions
- Microsoft Visual Studio 2019: 16.0
- Microsoft Visual Studio Code: all versions
How to fix
Upgrade to a fixed version: Microsoft Visual Studio 2017 version 15.9 (includes 15.0 - 15.8) 15.9.25; Microsoft Visual Studio 2019 16.0.16, 16.4.11, 16.6.4; Microsoft Visual Studio Code 1.47.1. Check the vendor advisory for mitigations.
References
- https://portal.msrc.microsoft.com/en-US/security-guidance/advisory/CVE-2020-1416
- https://portal.msrc.microsoft.com/en-US/security-guidance/advisory/CVE-2020-1416
Get alerted when CVE-2020-1416 or the next vulnerability affects your stack