What’s Vulnerable › Vulnerabilities
CVE-2020-14162
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-07-30 · updated 2026-06-17
- Weakness: CWE-78
Description
An issue was discovered in Pi-Hole through 5.0. The local www-data user has sudo privileges to execute the pihole core script as root without a password, which could allow an attacker to obtain root access via shell metacharacters to this script's setdns command.
Affected products
- pi-hole: before 5.1 — fixed in 5.1
How to fix
Upgrade to a fixed version: pi-hole 5.1. Check the vendor advisory for mitigations.
References
- https://0xpanic.github.io/2020/07/21/Pihole.html
- https://docs.pi-hole.net/core/pihole-command/
- https://0xpanic.github.io/2020/07/21/Pihole.html
- https://docs.pi-hole.net/core/pihole-command/
Get alerted when CVE-2020-14162 or the next vulnerability affects your stack