What’s Vulnerable › Vulnerabilities
CVE-2020-14175
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-07-24 · updated 2026-06-17
- Weakness: CWE-79
Description
Affected versions of Atlassian Confluence Server and Data Center allow remote attackers to inject arbitrary HTML or JavaScript via a Cross-Site Scripting (XSS) vulnerability in user macro parameters. The affected versions are before version 7.4.2, and from version 7.5.0 before 7.5.2.
Affected products
- Atlassian Confluence Data Center: before 7.4.2; from 7.5.0 before 7.5.2 — fixed in 7.4.2, 7.5.2
- Atlassian Confluence Data Center: before 7.4.2; from 7.5.0 before 7.5.2 — fixed in 7.4.2, 7.5.2
How to fix
Upgrade to a fixed version: Atlassian Confluence Data Center 7.4.2, 7.5.2; Atlassian Confluence Data Center 7.4.2, 7.5.2. Check the vendor advisory for mitigations.
References
- https://jira.atlassian.com/browse/CONFSERVER-60102
- https://jira.atlassian.com/browse/CONFSERVER-60102
Get alerted when CVE-2020-14175 or the next vulnerability affects your stack