What’s Vulnerable › Vulnerabilities
CVE-2020-14190
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-11-25 · updated 2026-06-17
- Weakness: CWE-400
Description
Affected versions of Atlassian Fisheye/Crucible allow remote attackers to achieve Regex Denial of Service via user-supplied regex in EyeQL. The affected versions are before version 4.8.4.
Affected products
- Atlassian Crucible: before 4.8.4 — fixed in 4.8.4
- Atlassian Fisheye: before 4.8.4 — fixed in 4.8.4
How to fix
Upgrade to a fixed version: Atlassian Crucible 4.8.4; Atlassian Fisheye 4.8.4. Check the vendor advisory for mitigations.
References
- https://jira.atlassian.com/browse/CRUC-8498
- https://jira.atlassian.com/browse/FE-7336
- https://jira.atlassian.com/browse/CRUC-8498
- https://jira.atlassian.com/browse/FE-7336
Get alerted when CVE-2020-14190 or the next vulnerability affects your stack