What’s Vulnerable › Vulnerabilities
CVE-2020-14212
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-06-16 · updated 2026-06-17
- Weakness: CWE-787
Description
FFmpeg through 4.3 has a heap-based buffer overflow in avio_get_str in libavformat/aviobuf.c because dnn_backend_native.c calls ff_dnn_load_model_native and a certain index check is omitted.
Affected products
- FFmpeg: from 4.3 before 4.3.1 — fixed in 4.3.1
How to fix
Upgrade to a fixed version: FFmpeg 4.3.1. Check the vendor advisory for mitigations.
References
- https://patchwork.ffmpeg.org/project/ffmpeg/list/?series=1463
- https://security.gentoo.org/glsa/202007-58
- https://trac.ffmpeg.org/ticket/8716
- https://patchwork.ffmpeg.org/project/ffmpeg/list/?series=1463
- https://security.gentoo.org/glsa/202007-58
- https://trac.ffmpeg.org/ticket/8716
Get alerted when CVE-2020-14212 or the next vulnerability affects your stack