What’s Vulnerable › Vulnerabilities
CVE-2020-14318
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-12-03 · updated 2026-06-17
- Weakness: CWE-266
Description
A flaw was found in the way samba handled file and directory permissions. An authenticated user could use this flaw to gain access to certain file and directory information which otherwise would be unavailable to the attacker.
Affected products
- Red Hat Enterprise Linux: 7.0, 8.0
- RedHat Storage: 3.0
- Samba: from 3.6.0 before 4.11.15; from 4.12.0 before 4.12.9; from 4.13.0 before 4.13.1 — fixed in 4.11.15, 4.12.9, 4.13.1
How to fix
Upgrade to a fixed version: Samba 4.11.15, 4.12.9, 4.13.1. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1892631
- https://lists.debian.org/debian-lts-announce/2024/04/msg00015.html
- https://security.gentoo.org/glsa/202012-24
- https://www.samba.org/samba/security/CVE-2020-14318.html
- https://bugzilla.redhat.com/show_bug.cgi?id=1892631
- https://lists.debian.org/debian-lts-announce/2024/04/msg00015.html
- https://security.gentoo.org/glsa/202012-24
- https://www.samba.org/samba/security/CVE-2020-14318.html
Get alerted when CVE-2020-14318 or the next vulnerability affects your stack