What’s Vulnerable › Vulnerabilities
CVE-2020-14319
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-08-03 · updated 2026-06-17
- Weakness: CWE-352
Description
It was found that the AMQ Online console is vulnerable to a Cross-Site Request Forgery (CSRF) which is exploitable in cases where preflight checks are not instigated or bypassed. For example authorised users using an older browser with Adobe Flash are vulnerable when targeted by an attacker. This flaw affects all versions of AMQ-Online prior to 1.5.2 and Enmasse versions 0.31.0-rc1 up until but not including 0.32.2.
Affected products
- AMQ: before 1.5.2 — fixed in 1.5.2
- RedHat Enmasse: before 0.32.2 — fixed in 0.32.2
How to fix
Upgrade to a fixed version: AMQ 1.5.2; RedHat Enmasse 0.32.2. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1854373
- https://bugzilla.redhat.com/show_bug.cgi?id=1854373
Get alerted when CVE-2020-14319 or the next vulnerability affects your stack