What’s Vulnerable › Vulnerabilities
CVE-2020-14321
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 16.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-16 · updated 2026-06-17
- Weakness: CWE-863
Description
In Moodle before 3.9.1, 3.8.4, 3.7.7 and 3.5.13, teachers of a course were able to assign themselves the manager role within that course.
Affected products
- Moodle: from 3.5.0 before 3.5.13; from 3.7.0 before 3.7.7; from 3.8.0 before 3.8.4; 3.9.0 — fixed in 3.5.13, 3.7.7, 3.8.4
How to fix
Upgrade to a fixed version: Moodle 3.5.13, 3.7.7, 3.8.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2020-14321 or the next vulnerability affects your stack