What’s Vulnerable › Vulnerabilities
CVE-2020-14327
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-05-27 · updated 2026-06-17
- Weakness: CWE-918
Description
A Server-side request forgery (SSRF) flaw was found in Ansible Tower in versions before 3.6.5 and before 3.7.2. Functionality on the Tower server is abused by supplying a URL that could lead to the server processing it. This flaw leads to the connection to internal services or the exposure of additional internal services by abusing the test feature of lookup credentials to forge HTTP/HTTPS requests from the server and retrieving the results of the response.
Affected products
- Tower: before 3.6.5; from 3.7.0 before 3.7.2 — fixed in 3.6.5, 3.7.2
How to fix
Upgrade to a fixed version: Tower 3.6.5, 3.7.2. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1856785
- https://bugzilla.redhat.com/show_bug.cgi?id=1856785
Get alerted when CVE-2020-14327 or the next vulnerability affects your stack