What’s Vulnerable › Vulnerabilities
CVE-2020-14328
- Severity: low (CVSS 3.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-05-27 · updated 2026-06-17
- Weakness: CWE-918
Description
A flaw was found in Ansible Tower in versions before 3.7.2. A Server Side Request Forgery flaw can be abused by supplying a URL which could lead to the server processing it connecting to internal services or exposing additional internal services and more particularly retrieving full details in case of error. The highest threat from this vulnerability is to data confidentiality.
Affected products
- Tower: before 3.7.2 — fixed in 3.7.2
How to fix
Upgrade to a fixed version: Tower 3.7.2. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1856786
- https://bugzilla.redhat.com/show_bug.cgi?id=1856786
Get alerted when CVE-2020-14328 or the next vulnerability affects your stack