What’s Vulnerable › Vulnerabilities
CVE-2020-14338
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-09-17 · updated 2026-06-17
- Weakness: CWE-20
Description
A flaw was found in Wildfly's implementation of Xerces, specifically in the way the XMLSchemaValidator class in the JAXP component of Wildfly enforced the "use-grammar-pool-only" feature. This flaw allows a specially-crafted XML file to manipulate the validation process in certain cases. This issue is the same flaw as CVE-2020-14621, which affected OpenJDK, and uses a similar code. This flaw affects all Xerces JBoss versions before 2.12.0.SP3.
Affected products
- RedHat Xerces: before 2.12.0; 2.12.0-sp1, 2.12.0-sp2 — fixed in 2.12.0
How to fix
Upgrade to a fixed version: RedHat Xerces 2.12.0. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1860054
- https://lists.apache.org/thread.html/rf96c5afb26b596b4b97883aa90b6c0b0fc4c26aaeea7123c21912103%40%3Cj-users.xerces.apache.org%3E
- https://bugzilla.redhat.com/show_bug.cgi?id=1860054
- https://lists.apache.org/thread.html/rf96c5afb26b596b4b97883aa90b6c0b0fc4c26aaeea7123c21912103%40%3Cj-users.xerces.apache.org%3E
Get alerted when CVE-2020-14338 or the next vulnerability affects your stack