What’s Vulnerable › Vulnerabilities
CVE-2020-14339
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-12-03 · updated 2026-06-17
- Weakness: CWE-772
Description
A flaw was found in libvirt, where it leaked a file descriptor for `/dev/mapper/control` into the QEMU process. This file descriptor allows for privileged operations to happen against the device-mapper on the host. This flaw allows a malicious guest user or process to perform operations outside of their standard permissions, potentially causing serious damage to the host operating system. The highest threat from this vulnerability is to confidentiality, integrity, as well as system availability.
Affected products
- Red Hat Enterprise Linux: 8.0
- libvirt: from 6.2.0 before 6.7.0 — fixed in 6.7.0
How to fix
Upgrade to a fixed version: libvirt 6.7.0. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1860069
- https://security.gentoo.org/glsa/202101-22
- https://security.gentoo.org/glsa/202210-06
- https://bugzilla.redhat.com/show_bug.cgi?id=1860069
- https://security.gentoo.org/glsa/202101-22
- https://security.gentoo.org/glsa/202210-06
Get alerted when CVE-2020-14339 or the next vulnerability affects your stack