What’s Vulnerable › Vulnerabilities
CVE-2020-14347
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-08-05 · updated 2026-06-17
- Weakness: CWE-665
Description
A flaw was found in the way xserver memory was not properly initialized. This could leak parts of server memory to the X client. In cases where Xorg server runs with elevated privileges, this could result in possible ASLR bypass. Xorg-server before version 1.20.9 is vulnerable.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04, 20.04
- Debian Linux: 9.0, 10.0
- xorg-x11-server: before 1.20.9 — fixed in 1.20.9
How to fix
Upgrade to a fixed version: xorg-x11-server 1.20.9. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-08/msg00066.html
- http://lists.opensuse.org/opensuse-security-announce/2020-08/msg00075.html
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2020-14347
- https://lists.debian.org/debian-lts-announce/2020/08/msg00057.html
- https://lists.x.org/archives/xorg-announce/2020-July/003051.html
- https://security.gentoo.org/glsa/202012-01
- https://usn.ubuntu.com/4488-1/
- https://usn.ubuntu.com/4488-2/
- https://www.debian.org/security/2020/dsa-4758
- https://www.openwall.com/lists/oss-security/2020/07/31/2
- http://lists.opensuse.org/opensuse-security-announce/2020-08/msg00066.html
- http://lists.opensuse.org/opensuse-security-announce/2020-08/msg00075.html
Get alerted when CVE-2020-14347 or the next vulnerability affects your stack