What’s Vulnerable › Vulnerabilities
CVE-2020-14364
- Severity: medium (CVSS 5.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-08-31 · updated 2026-06-17
- Weakness: CWE-125
Description
An out-of-bounds read/write access flaw was found in the USB emulator of the QEMU in versions before 5.2.0. This issue occurs while processing USB packets from a guest when USBDevice 'setup_len' exceeds its 'data_buf[4096]' in the do_token_in, do_token_out routines. This flaw allows a guest user to crash the QEMU process, resulting in a denial of service, or the potential execution of arbitrary code with the privileges of the QEMU process on the host.
Affected products
- Canonical Ubuntu Linux: 16.04, 18.04, 20.04
- Debian Linux: 9.0, 10.0
- Fedoraproject Fedora: 31, 32
- openSUSE Leap: 15.2
- QEMU: before 5.2.0 — fixed in 5.2.0
- Red Hat Enterprise Linux: 6.0, 7.0, 8.0
- OpenStack: 10, 13
How to fix
Upgrade to a fixed version: QEMU 5.2.0. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00024.html
- https://bugzilla.redhat.com/show_bug.cgi?id=1869201
- https://lists.debian.org/debian-lts-announce/2020/09/msg00013.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/JTZQUQ6ZBPMFMNAUQBVJFELYNMUZLL6P/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/M52WIRMZL6TZRYZ65N6OAYNNFHV62O2N/
- https://security.gentoo.org/glsa/202009-14
- https://security.gentoo.org/glsa/202011-09
- https://security.netapp.com/advisory/ntap-20200924-0006/
- https://usn.ubuntu.com/4511-1/
- https://www.debian.org/security/2020/dsa-4760
- https://www.openwall.com/lists/oss-security/2020/08/24/2
- https://www.openwall.com/lists/oss-security/2020/08/24/3
Get alerted when CVE-2020-14364 or the next vulnerability affects your stack