What’s Vulnerable › Vulnerabilities
CVE-2020-14374
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-09-30 · updated 2026-06-17
- Weakness: CWE-120
Description
A flaw was found in dpdk in versions before 18.11.10 and before 19.11.5. A flawed bounds checking in the copy_data function leads to a buffer overflow allowing an attacker in a virtual machine to write arbitrary data to any address in the vhost_crypto application. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.
Affected products
- Canonical Ubuntu Linux: 20.04
- DPDK Data Plane Development Kit: from 18.02.1 before 18.11.10; from 19.02 before 19.11.5 — fixed in 18.11.10, 19.11.5
- openSUSE Leap: 15.1, 15.2
How to fix
Upgrade to a fixed version: DPDK Data Plane Development Kit 18.11.10, 19.11.5. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00004.html
- http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00006.html
- http://www.openwall.com/lists/oss-security/2021/01/04/1
- http://www.openwall.com/lists/oss-security/2021/01/04/2
- http://www.openwall.com/lists/oss-security/2021/01/04/5
- https://bugzilla.redhat.com/show_bug.cgi?id=1879466
- https://www.openwall.com/lists/oss-security/2020/09/28/3
- http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00004.html
- http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00006.html
- http://www.openwall.com/lists/oss-security/2021/01/04/1
- http://www.openwall.com/lists/oss-security/2021/01/04/2
- http://www.openwall.com/lists/oss-security/2021/01/04/5
Get alerted when CVE-2020-14374 or the next vulnerability affects your stack