What’s Vulnerable › Vulnerabilities
CVE-2020-14390
- Severity: medium (CVSS 5.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-09-18 · updated 2026-10-08
- Weakness: CWE-787
Description
A flaw was found in the Linux kernel in versions before 5.9-rc6. When changing screen size, an out-of-bounds memory write can occur leading to memory corruption or a denial of service. Due to the nature of the flaw, privilege escalation cannot be fully ruled out.
Affected products
- Debian Linux: 9.0
- Linux kernel: from 2.2.3 before 5.9.0; 5.9.0, 5.9.0-rc1, 5.9.0-rc2, 5.9.0-rc3, 5.9.0-rc4, 5.9.0-rc5 — fixed in 5.9.0
How to fix
Upgrade to a fixed version: Linux kernel 5.9.0. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00001.html
- http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00021.html
- https://bugzilla.redhat.com/show_bug.cgi?id=1876788
- https://lists.debian.org/debian-lts-announce/2020/10/msg00032.html
- https://lists.debian.org/debian-lts-announce/2020/10/msg00034.html
- http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00001.html
- http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00021.html
- https://bugzilla.redhat.com/show_bug.cgi?id=1876788
- https://lists.debian.org/debian-lts-announce/2020/10/msg00032.html
- https://lists.debian.org/debian-lts-announce/2020/10/msg00034.html
Get alerted when CVE-2020-14390 or the next vulnerability affects your stack