What’s Vulnerable › Vulnerabilities
CVE-2020-14393
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-09-16 · updated 2026-06-17
- Weakness: CWE-121
Description
A buffer overflow was found in perl-DBI < 1.643 in DBI.xs. A local attacker who is able to supply a string longer than 300 characters could cause an out-of-bounds write, affecting the availability of the service or integrity of data.
Affected products
- Debian Linux: 9.0
- Fedoraproject Fedora: 31
- openSUSE Leap: 15.2
- perl Database Interface: before 1.643 — fixed in 1.643
How to fix
Upgrade to a fixed version: perl Database Interface 1.643. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-09/msg00067.html
- http://lists.opensuse.org/opensuse-security-announce/2020-09/msg00074.html
- https://bugzilla.redhat.com/show_bug.cgi?id=1877409
- https://lists.debian.org/debian-lts-announce/2020/09/msg00026.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/JXLKODJ7B57GITDEZZXNSHPK4VBYXYHR/
- https://metacpan.org/pod/distribution/DBI/Changes#Changes-in-DBI-1.643
- http://lists.opensuse.org/opensuse-security-announce/2020-09/msg00067.html
- http://lists.opensuse.org/opensuse-security-announce/2020-09/msg00074.html
- https://bugzilla.redhat.com/show_bug.cgi?id=1877409
- https://lists.debian.org/debian-lts-announce/2020/09/msg00026.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/JXLKODJ7B57GITDEZZXNSHPK4VBYXYHR/
- https://metacpan.org/pod/distribution/DBI/Changes#Changes-in-DBI-1.643
Get alerted when CVE-2020-14393 or the next vulnerability affects your stack