What’s Vulnerable › Vulnerabilities
CVE-2020-14418
- Severity: high (CVSS 7.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-01-30 · updated 2026-06-17
- Weakness: CWE-367
Description
A TOCTOU vulnerability exists in madCodeHook before 2020-07-16 that allows local attackers to elevate their privileges to SYSTEM. This occurs because path redirection can occur via vectors involving directory junctions.
Affected products
- Cisco Advanced Malware Protection: before 7.2.13 — fixed in 7.2.13
- Madshi Madcodehook: before 4.1.3 — fixed in 4.1.3
- Morphisec Unified Threat Prevention Platform: before 3.5.9; from 4.0 before 4.1.2 — fixed in 3.5.9, 4.1.2
How to fix
Upgrade to a fixed version: Cisco Advanced Malware Protection 7.2.13; Madshi Madcodehook 4.1.3; Morphisec Unified Threat Prevention Platform 3.5.9, 4.1.2. Check the vendor advisory for mitigations.
References
- https://github.com/nettitude/metasploit-modules
- https://labs.nettitude.com/blog/cve-2020-14418-madcodehook-library-local-privilege-escalation/
- https://github.com/nettitude/metasploit-modules
- https://labs.nettitude.com/blog/cve-2020-14418-madcodehook-library-local-privilege-escalation/
Get alerted when CVE-2020-14418 or the next vulnerability affects your stack