What’s Vulnerable › Vulnerabilities
CVE-2020-14470
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-06-19 · updated 2026-06-17
- Weakness: CWE-532
Description
In Octopus Deploy 2018.8.0 through 2019.x before 2019.12.2, an authenticated user with could trigger a deployment that leaks the Helm Chart repository password.
Affected products
- Octopus Deploy: from 2018.8.0 before 2019.12.2 — fixed in 2019.12.2
How to fix
Upgrade to a fixed version: Octopus Deploy 2019.12.2. Check the vendor advisory for mitigations.
References
- https://github.com/OctopusDeploy/Issues/issues/6438
- https://github.com/OctopusDeploy/Issues/issues/6438
Get alerted when CVE-2020-14470 or the next vulnerability affects your stack