What’s Vulnerable › Vulnerabilities
CVE-2020-14509
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-09-16 · updated 2026-06-17
- Weakness: CWE-805
Description
Multiple memory corruption vulnerabilities exist in CodeMeter (All versions prior to 7.10) where the packet parser mechanism does not verify length fields. An attacker could send specially crafted packets to exploit these vulnerabilities.
Affected products
- CodeMeter: before 7.10 — fixed in 7.10
How to fix
Upgrade to a fixed version: CodeMeter 7.10. Check the vendor advisory for mitigations.
References
- https://us-cert.cisa.gov/ics/advisories/icsa-20-203-01
- https://us-cert.cisa.gov/ics/advisories/icsa-20-203-01
Get alerted when CVE-2020-14509 or the next vulnerability affects your stack