What’s Vulnerable › Vulnerabilities
CVE-2020-14517
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-09-16 · updated 2026-06-17
- Weakness: CWE-326
Description
Protocol encryption can be easily broken for CodeMeter (All versions prior to 6.90 are affected, including Version 6.90 or newer only if CodeMeter Runtime is running as server) and the server accepts external connections, which may allow an attacker to remotely communicate with the CodeMeter API.
Affected products
- CodeMeter: before 6.90 — fixed in 6.90
How to fix
Upgrade to a fixed version: CodeMeter 6.90. Check the vendor advisory for mitigations.
References
- https://us-cert.cisa.gov/ics/advisories/icsa-20-203-01
- https://us-cert.cisa.gov/ics/advisories/icsa-20-203-01
Get alerted when CVE-2020-14517 or the next vulnerability affects your stack