What’s Vulnerable › Vulnerabilities
CVE-2020-14519
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-09-16 · updated 2026-06-17
- Weakness: CWE-346
Description
This vulnerability allows an attacker to use the internal WebSockets API for CodeMeter (All versions prior to 7.00 are affected, including Version 7.0 or newer with the affected WebSockets API still enabled. This is especially relevant for systems or devices where a web browser is used to access a web server) via a specifically crafted Java Script payload, which may allow alteration or creation of license files for when combined with CVE-2020-14515.
Affected products
- CodeMeter: before 7.00 — fixed in 7.00
How to fix
Upgrade to a fixed version: CodeMeter 7.00. Check the vendor advisory for mitigations.
References
- https://us-cert.cisa.gov/ics/advisories/icsa-20-203-01
- https://us-cert.cisa.gov/ics/advisories/icsa-20-203-01
Get alerted when CVE-2020-14519 or the next vulnerability affects your stack