What’s Vulnerable › Vulnerabilities
CVE-2020-14967
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-06-22 · updated 2026-06-22
- Weakness: CWE-119
Description
An issue was discovered in the jsrsasign package before 8.0.18 for Node.js. Its RSA PKCS1 v1.5 decryption implementation does not detect ciphertext modification by prepending '\0' bytes to ciphertexts (it decrypts modified ciphertexts without error). An attacker might prepend these bytes with the goal of triggering memory corruption issues.
Affected products
- jsrsasign: before 8.0.18 — fixed in 8.0.18
- NetApp Max Data: all versions
How to fix
Upgrade to a fixed version: jsrsasign 8.0.18. Check the vendor advisory for mitigations.
References
- https://github.com/kjur/jsrsasign/issues/439
- https://github.com/kjur/jsrsasign/releases/tag/8.0.17
- https://github.com/kjur/jsrsasign/releases/tag/8.0.18
- https://kjur.github.io/jsrsasign/
- https://security.netapp.com/advisory/ntap-20200724-0001/
- https://www.npmjs.com/package/jsrsasign
- https://github.com/kjur/jsrsasign/issues/439
- https://github.com/kjur/jsrsasign/releases/tag/8.0.17
- https://github.com/kjur/jsrsasign/releases/tag/8.0.18
- https://kjur.github.io/jsrsasign/
- https://security.netapp.com/advisory/ntap-20200724-0001/
- https://www.npmjs.com/package/jsrsasign
Get alerted when CVE-2020-14967 or the next vulnerability affects your stack