What’s Vulnerable › Vulnerabilities
CVE-2020-15011
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-06-24 · updated 2026-06-17
- Weakness: CWE-74
Description
GNU Mailman before 2.1.33 allows arbitrary content injection via the Cgi/private.py private archive login page.
Affected products
- Canonical Ubuntu Linux: 16.04, 18.04
- Debian Linux: 8.0, 9.0, 10.0
- GNU Mailman: before 2.1.33 — fixed in 2.1.33
How to fix
Upgrade to a fixed version: GNU Mailman 2.1.33. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00047.html
- http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00063.html
- https://bugs.launchpad.net/mailman/+bug/1877379
- https://lists.debian.org/debian-lts-announce/2020/06/msg00036.html
- https://lists.debian.org/debian-lts-announce/2020/07/msg00007.html
- https://usn.ubuntu.com/4406-1/
- https://www.debian.org/security/2021/dsa-4991
- http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00047.html
- http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00063.html
- https://bugs.launchpad.net/mailman/+bug/1877379
- https://lists.debian.org/debian-lts-announce/2020/06/msg00036.html
- https://lists.debian.org/debian-lts-announce/2020/07/msg00007.html
Get alerted when CVE-2020-15011 or the next vulnerability affects your stack