What’s Vulnerable › Vulnerabilities
CVE-2020-15027
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-07-16 · updated 2026-06-17
- Weakness: CWE-287
Description
ConnectWise Automate through 2020.x has insufficient validation on certain authentication paths, allowing authentication bypass via a series of attempts. This was patched in 2020.7 and in a hotfix for 2019.12.
Affected products
- ConnectWise Automate: before 2019.12; from 2020.0 through 2020.7 — fixed in 2019.12
How to fix
Upgrade to a fixed version: ConnectWise Automate 2019.12. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2020-15027 or the next vulnerability affects your stack