What’s Vulnerable › Vulnerabilities
CVE-2020-15070
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-08-21 · updated 2026-06-17
- Weakness: CWE-94
Description
Zulip Server 2.x before 2.1.7 allows eval injection if a privileged attacker were able to write directly to the postgres database, and chose to write a crafted custom profile field value.
Affected products
- zulip: before 2.1.7 — fixed in 2.1.7
How to fix
Upgrade to a fixed version: zulip 2.1.7. Check the vendor advisory for mitigations.
References
- https://blog.zulip.com/2020/06/26/zulip-server-2-1-7-security-release/
- https://blog.zulip.com/2020/06/26/zulip-server-2-1-7-security-release/
Get alerted when CVE-2020-15070 or the next vulnerability affects your stack