What’s Vulnerable › Vulnerabilities
CVE-2020-15079: Improper access control in PrestaShop
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-07-02 · updated 2026-06-17
- Weakness: CWE-284
Description
In PrestaShop from version 1.5.0.0 and before version 1.7.6.6, there is improper access control in Carrier page, Module Manager and Module Positions. The problem is fixed in version 1.7.6.6
Affected products
- PrestaShop: from 1.5.0.0 (excl.) before 1.7.6.6 — fixed in 1.7.6.6
How to fix
Upgrade to a fixed version: PrestaShop 1.7.6.6. Check the vendor advisory for mitigations.
References
- https://github.com/PrestaShop/PrestaShop/commit/8833d9504cc5d69a2a6d10197f56f0c11443cbfa
- https://github.com/PrestaShop/PrestaShop/security/advisories/GHSA-xp3x-3h8q-c386
- https://github.com/PrestaShop/PrestaShop/commit/8833d9504cc5d69a2a6d10197f56f0c11443cbfa
- https://github.com/PrestaShop/PrestaShop/security/advisories/GHSA-xp3x-3h8q-c386
Get alerted when CVE-2020-15079 or the next vulnerability affects your stack