What’s Vulnerable › Vulnerabilities
CVE-2020-15084: Authorization bypass in express-jwt
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-06-30 · updated 2026-06-17
- Weakness: CWE-285
Description
In express-jwt (NPM package) up and including version 5.3.3, the algorithms entry to be specified in the configuration is not being enforced. When algorithms is not specified in the configuration, with the combination of jwks-rsa, it may lead to authorization bypass. You are affected by this vulnerability if all of the following conditions apply: - You are using express-jwt - You do not have **algorithms** configured in your express-jwt configuration. - You are using libraries such as jwks-rsa as the **secret**. You can fix this by specifying **algorithms** in the express-jwt configuration. See linked GHSA for example. This is also fixed in version 6.0.0.
Affected products
- auth0 express-jwt: through 5.3.3
References
- https://github.com/auth0/express-jwt/commit/7ecab5f8f0cab5297c2b863596566eb0c019cdef
- https://github.com/auth0/express-jwt/security/advisories/GHSA-6g6m-m6h5-w9gf
- https://github.com/auth0/express-jwt/commit/7ecab5f8f0cab5297c2b863596566eb0c019cdef
- https://github.com/auth0/express-jwt/security/advisories/GHSA-6g6m-m6h5-w9gf
Get alerted when CVE-2020-15084 or the next vulnerability affects your stack