What’s Vulnerable › Vulnerabilities
CVE-2020-15086: Potential Remote Code Execution in TYPO3 with mediace extension
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-07-29 · updated 2026-06-17
- Weakness: CWE-20
Description
In TYPO3 installations with the "mediace" extension from version 7.6.2 and before version 7.6.5, it has been discovered that an internal verification mechanism can be used to generate arbitrary checksums. The allows to inject arbitrary data having a valid cryptographic message authentication code and can lead to remote code execution. To successfully exploit this vulnerability, an attacker must have access to at least one `Extbase` plugin or module action in a TYPO3 installation. This is fixed in version 7.6.5 of the "mediace" extension for TYPO3.
Affected products
- FriendsOfTYPO3 mediace: from 7.6.2 before 7.6.5 — fixed in 7.6.5
How to fix
Upgrade to a fixed version: FriendsOfTYPO3 mediace 7.6.5. Check the vendor advisory for mitigations.
References
- https://github.com/FriendsOfTYPO3/mediace/commit/fa29ffd3e8b275782a8600d2406e1b1e5e16ae75
- https://github.com/FriendsOfTYPO3/mediace/pull/31
- https://github.com/FriendsOfTYPO3/mediace/security/advisories/GHSA-4h44-w6fm-548g
- https://github.com/FriendsOfTYPO3/mediace/commit/fa29ffd3e8b275782a8600d2406e1b1e5e16ae75
- https://github.com/FriendsOfTYPO3/mediace/pull/31
- https://github.com/FriendsOfTYPO3/mediace/security/advisories/GHSA-4h44-w6fm-548g
Get alerted when CVE-2020-15086 or the next vulnerability affects your stack