What’s Vulnerable › Vulnerabilities
CVE-2020-15098: Missing Required Cryptographic Step Leading to Sensitive Information Disclosure in TYPO3 CMS
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-07-29 · updated 2026-06-17
- Weakness: CWE-20
Description
In TYPO3 CMS greater than or equal to 9.0.0 and less than 9.5.20, and greater than or equal to 10.0.0 and less than 10.4.6, it has been discovered that an internal verification mechanism can be used to generate arbitrary checksums. This allows to inject arbitrary data having a valid cryptographic message authentication code (HMAC-SHA1) and can lead to various attack chains including potential privilege escalation, insecure deserialization & remote code execution. The overall severity of this vulnerability is high based on mentioned attack chains and the requirement of having a valid backend user session (authenticated). This has been patched in versions 9.5.20 and 10.4.6.
Affected products
- typo3: from 9.0.0 before 9.5.20; from 10.0.0 before 10.4.6 — fixed in 10.4.6, 9.5.20
How to fix
Upgrade to a fixed version: typo3 10.4.6, 9.5.20. Check the vendor advisory for mitigations.
References
- https://github.com/TYPO3/TYPO3.CMS/commit/85d3e70dff35a99ef53f4b561114acfa9e5c47e1
- https://github.com/TYPO3/TYPO3.CMS/security/advisories/GHSA-m5vr-3m74-jwxp
- https://typo3.org/security/advisory/typo3-core-sa-2016-013
- https://typo3.org/security/advisory/typo3-core-sa-2020-008
- https://github.com/TYPO3/TYPO3.CMS/commit/85d3e70dff35a99ef53f4b561114acfa9e5c47e1
- https://github.com/TYPO3/TYPO3.CMS/security/advisories/GHSA-m5vr-3m74-jwxp
- https://typo3.org/security/advisory/typo3-core-sa-2016-013
- https://typo3.org/security/advisory/typo3-core-sa-2020-008
Get alerted when CVE-2020-15098 or the next vulnerability affects your stack