What’s Vulnerable › Vulnerabilities
CVE-2020-15104: TLS Validation Vulnerability in Envoy
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-07-14 · updated 2026-06-17
- Weakness: CWE-346
Description
In Envoy before versions 1.12.6, 1.13.4, 1.14.4, and 1.15.0 when validating TLS certificates, Envoy would incorrectly allow a wildcard DNS Subject Alternative Name apply to multiple subdomains. For example, with a SAN of *.example.com, Envoy would incorrectly allow nested.subdomain.example.com, when it should only allow subdomain.example.com. This defect applies to both validating a client TLS certificate in mTLS, and validating a server TLS certificate for upstream connections. This vulnerability is only applicable to situations where an untrusted entity can obtain a signed wildcard TLS certificate for a domain of which you only intend to trust a subdomain of. For example, if you intend to trust api.mysubdomain.example.com, and an untrusted actor can obtain a signed TLS certificate for *.example.com or *.com. Configurations are vulnerable if they use verify_subject_alt_name in any Envoy version, or if they use match_subject_alt_names in version 1.14 or later. This issue has been fixed in Envoy versions 1.12.6, 1.13.4, 1.14.4, 1.15.0.
Affected products
- envoyproxy envoy: before 1.12.6; from 1.13.0 before 1.13.4; from 1.14.0 before 1.14.4 — fixed in 1.12.6, 1.13.4, 1.14.4
How to fix
Upgrade to a fixed version: envoyproxy envoy 1.12.6, 1.13.4, 1.14.4. Check the vendor advisory for mitigations.
References
- https://github.com/envoyproxy/envoy/security/advisories/GHSA-w5f5-6qhq-hhrg
- https://github.com/envoyproxy/envoy/security/advisories/GHSA-w5f5-6qhq-hhrg
Get alerted when CVE-2020-15104 or the next vulnerability affects your stack