What’s Vulnerable › Vulnerabilities
CVE-2020-15106: Improper Input Validation in etcd
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-08-05 · updated 2026-06-17
- Weakness: CWE-20
Description
In etcd before versions 3.3.23 and 3.4.10, a large slice causes panic in decodeRecord method. The size of a record is stored in the length field of a WAL file and no additional validation is done on this data. Therefore, it is possible to forge an extremely large frame size that can unintentionally panic at the expense of any RAFT participant trying to decode the WAL.
Affected products
- etcd-io etcd: before 3.3.23; from 3.4.0 before 3.4.10 — fixed in 3.3.23, 3.4.10
- Fedoraproject Fedora: 32
How to fix
Upgrade to a fixed version: etcd-io etcd 3.3.23, 3.4.10. Check the vendor advisory for mitigations.
References
- https://github.com/etcd-io/etcd/security/advisories/GHSA-p4g4-wgrh-qrg2
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/L6B6R43Y7M3DCHWK3L3UVGE2K6WWECMP/
- https://github.com/etcd-io/etcd/security/advisories/GHSA-p4g4-wgrh-qrg2
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/L6B6R43Y7M3DCHWK3L3UVGE2K6WWECMP/
Get alerted when CVE-2020-15106 or the next vulnerability affects your stack