What’s Vulnerable › Vulnerabilities
CVE-2020-15115: No minimum password length in etcd
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-08-06 · updated 2026-06-17
- Weakness: CWE-521
Description
etcd before versions 3.3.23 and 3.4.10 does not perform any password length validation, which allows for very short passwords, such as those with a length of one. This may allow an attacker to guess or brute-force users' passwords with little computational effort.
Affected products
- Fedoraproject Fedora: 32
- RedHat Etcd: from 3.3.0 before 3.3.23; from 3.4.0 before 3.4.10 — fixed in 3.3.23, 3.4.10
How to fix
Upgrade to a fixed version: RedHat Etcd 3.3.23, 3.4.10. Check the vendor advisory for mitigations.
References
- https://github.com/etcd-io/etcd/security/advisories/GHSA-4993-m7g5-r9hh
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/L6B6R43Y7M3DCHWK3L3UVGE2K6WWECMP/
- https://github.com/etcd-io/etcd/security/advisories/GHSA-4993-m7g5-r9hh
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/L6B6R43Y7M3DCHWK3L3UVGE2K6WWECMP/
Get alerted when CVE-2020-15115 or the next vulnerability affects your stack