What’s Vulnerable › Vulnerabilities
CVE-2020-15125: Authorization header is not sanitized in an error object in auth0
- Severity: high (CVSS 7.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-07-29 · updated 2026-06-17
- Weakness: CWE-209
Description
In auth0 (npm package) versions before 2.27.1, a DenyList of specific keys that should be sanitized from the request object contained in the error object is used. The key for Authorization header is not sanitized and in certain cases the Authorization header value can be logged exposing a bearer token. You are affected by this vulnerability if you are using the auth0 npm package, and you are using a Machine to Machine application authorized to use Auth0's management API
Affected products
- auth0.js: before 2.27.1 — fixed in 2.27.1
How to fix
Upgrade to a fixed version: auth0.js 2.27.1. Check the vendor advisory for mitigations.
References
- https://github.com/auth0/node-auth0/pull/507
- https://github.com/auth0/node-auth0/pull/507/commits/62ca61b3348ec8e74d7d00358661af1a8bc98a3c
- https://github.com/auth0/node-auth0/security/advisories/GHSA-5jpf-pj32-xx53
- https://github.com/auth0/node-auth0/tree/v2.27.1
- https://github.com/auth0/node-auth0/pull/507
- https://github.com/auth0/node-auth0/pull/507/commits/62ca61b3348ec8e74d7d00358661af1a8bc98a3c
- https://github.com/auth0/node-auth0/security/advisories/GHSA-5jpf-pj32-xx53
- https://github.com/auth0/node-auth0/tree/v2.27.1
Get alerted when CVE-2020-15125 or the next vulnerability affects your stack